Mark Minasi's Reader Forum
Mark Minasi's Reader Forum
Home | Profile | Register | Active Topics | Active Polls | Members | Search | FAQ | Minasi Forum RSS Feed
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 HALP! Questions on Windows and Windows Server
 Windows Server 2008
 Task Scheduler Permissions
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

dlevine
Welcome Newcomer

USA
10 Posts
Status: offline

Posted - 07/22/2008 :  1:43:20 PM  Show Profile  Send dlevine a Yahoo! Message  Reply with Quote
Hi all -

This is driving me NUTS!

I am configuring a large number of scheduled tasks on a new Windows 2008 Server. These tasks will need to be managed by various people.

I am logged in as (domain) administrator on the system as I am scheduling these tasks (setting them to run under regular user creds though). When I log in as a different user though (one that would be managing these jobs) I cannot see any of the tasks that I just setup.

I used to be able to edit the ACL of scheduled tasks using properties --> security tab, but this does not seem to be an option now?

Is there a way for me to set the ACL on scheduled tasks in 2008? Is there a way for me to make tasks that I configure as admin visible to others?

Thanks so much -

D

dlevine
Welcome Newcomer

USA
10 Posts
Status: offline

Posted - 07/22/2008 :  3:02:29 PM  Show Profile  Send dlevine a Yahoo! Message  Reply with Quote
Ok -

Looks like I am on to something here...

Located where the scheduled tasks are actually located - %SystemRoot%\system32\Tasks\<my custom tasks folder>
I set NTFS permissions here for the AD group that I want to have access... logged in with an account that is a member of that group and all the tasks are now visible in the Task Scheduler...

We'll see if that's all there is to it...

Thanks!

David
Go to Top of Page

dlevine
Welcome Newcomer

USA
10 Posts
Status: offline

Posted - 08/14/2008 :  11:30:16 AM  Show Profile  Send dlevine a Yahoo! Message  Reply with Quote
Here is something else that is strange with the task scheduler...

When I attempt to view task history I get an error message pop up that states:

Query Error
One or more logs in the query have errors
Log:Microsoft-Windows-TaskScheduler/Operational
Error: The specified query is invalid

This happens even when logged in as an admin... has anyone seen this before?

Go to Top of Page

Mark Minasi
Chief cook and bottle washer

USA
10768 Posts
Status: offline

Posted - 08/14/2008 :  9:54:18 PM  Show Profile  Visit Mark Minasi's Homepage  Reply with Quote
Hi David --

The short answer is "sadly I have no idea,<g>" (sorry), but I wonder if there are different levels of permissions on that folder? And I wonder what exactly the permission's been created on? Maybe looking at the security log might show the object that the error happened on... although object auditing may not be enabled on that object.

Perhaps Procmon might offer a clue about what's being accessed -- maybe something in the Registry?

Mark
tweetin' at mminasi
Go to Top of Page

dlevine
Welcome Newcomer

USA
10 Posts
Status: offline

Posted - 08/18/2008 :  1:33:13 PM  Show Profile  Send dlevine a Yahoo! Message  Reply with Quote
Thanks for the response Mark...

I did use procmon to attempt to identify where we are getting hung up, but I was not able identify any specific issue. oddly enough I *am* able to see history when looking at the main Task Scheduler Overview screen in the mmc snapin....

Strange... I can post the output of procmon if anyone is interested.

Thanks much,

D

Go to Top of Page

kendrome
Welcome Newcomer

USA
1 Posts
Status: offline

Posted - 04/15/2009 :  5:00:40 PM  Show Profile  Reply with Quote
Just in case, I had the same error -

Query Error
One or more logs in the query have errors
Log:Microsoft-Windows-TaskScheduler/Operational
Error: The specified query is invalid


It was because I had a single quote ' in the name of the task. Once I renamed the task it worked great, and I was able to see the history.
Go to Top of Page

sfeldner
Welcome Newcomer

USA
1 Posts
Status: offline

Posted - 01/23/2011 :  02:29:42 AM  Show Profile  Reply with Quote
quote:
Originally posted by kendrome

Just in case, I had the same error -


I too had the same error and it was caused by a single-quote in the folder name...
Very good catch kendrome!!!

Even though this is an old post, I hope it helps someone else...
Go to Top of Page

Xenophane
Honorable But Hopeless Addict

Denmark
3112 Posts
Status: offline

Posted - 01/23/2011 :  07:59:40 AM  Show Profile  Visit Xenophane's Homepage  Send Xenophane an ICQ Message  Reply with Quote
One thing to be aware of as well in 2008, is that when you create a scheduled task in the GUI, it uses a dateformat that schtasks.exe cannot read.. Meaning if you create a scheduled Task in the GUI, you cannot change it from the commandline.

Microsoft Powershell MVP

SIG> George Bernard Shaw : The power of accurate observation is commonly called cynicism by those who have not got it. </SIG>

You can read my blog at www.xipher.dk
Go to Top of Page

tbarrett
Welcome Newcomer

1 Posts
Status: offline

Posted - 01/10/2012 :  09:23:33 AM  Show Profile  Reply with Quote
I had the same problem and noticed that my folder name had an Apostrophe in it (i.e.: Tim's Tasks). When I changed it to Tims Tasks the issue went away. Unfortunately, I did not see a rename feature so I had to create a new folder in the Task Scheduler, export all my tasks in the other folder and import them into the new folder. Just a butch of right-click, left-click moves.

Hope it works for you.
Go to Top of Page

don2007
Honorable But Hopeless Addict

2164 Posts
Status: offline

Posted - 01/14/2012 :  8:41:47 PM  Show Profile  Reply with Quote
I would look at two commands, if they still exist:

cacls

&

at

The problem, with history is that the people who were there aren't talking & the people who weren't there won't stop talking.
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
Mark Minasi's Reader Forum © 2002-2011 Mark Minasi Go To Top Of Page
This page was generated in 0.08 seconds. Snitz Forums 2000